Unicenter Fast Unload for Sybase 33 - CA Technologies
{{search ? 'Close':'Search'}}

Unicenter Fast Unload for Sybase 3.3

1.0 Welcome

2.0 Operating System Support

3.0 System Requirements

4.0 Unicenter Database Management Common Services 2.6.0
4.1 System Requirements
4.2 Installation Considerations for Sybase and Oracle Agents
4.3 Post-Installation Server Setup
4.4 Platform Patch Requirements
4.5 Disabling Unicenter Enterprise DBA File Transfer Service

5.0 Contacting Technical Support


1.0 Welcome

Welcome to Unicenter Fast Unload for Sybase. Before you start using this version of Unicenter Fast Unload for Sybase, you should review these notes for important additional information to help you with your implementation of Unicenter Fast Unload for Sybase.


2.0 Operating System Support


Sun SPARC

Solaris 2.6, 2.7, 2.8

IBM RS/6000

AIX 4.3, 5.1

HP 9000/800, 700

HP-UX 11.00, 11.11

Windows Environment

Windows 2000 SP2

Windows NT 4.0 SP6a

Sybase

Sybase 11 (11.5, 11.9)

Sybase 12 (12.0, 12.5)


3.0 System Requirements

Fast Unload for Sybase requirements are:

RAM: 64MB

Disk space: 3MB (plus space required by Unicenter Database Management components)

Note: Unicenter Fast Unload for Sybase is designed to run with the 32-bit version of the Sybase OCS libraries. If you have not already done so, you need to install the 32-bit Sybase OCS libraries from Sybase and ensure that your library path points to them.


4.0 Unicenter Database Management Common Services 2.6.0


4.1 System Requirements

The Unicenter Database Management Common Services components disk space requirements are:

Component Windows Solaris AIX HPUX DEC OSF
Common Services 52 MB 15 MB 51 MB 21 MB 45 MB
PEC 6 MB 14 MB 51 MB 14 MB 13 MB
ODBC 5 MB 52 MB 49 MB 62 MB 19 MB


4.2 Installation Considerations for Sybase and Oracle Agents

If you install the Agent on the same Windows NT or Windows 2000 machine as the Unicenter Database Management Repository, you must configure the Unicenter Database Management Repository to start automatically on reboot.


4.3 Post-Installation Server Setup

After installing a new version of the Database Management Console, you must run Server Setup on all servers you want to access.

After performing a database discovery (see the Database Discovery section in the chapter "Planning Your Installation" in your product Getting Started guide), select a server icon in the DBMS Explorer portion of the Unicenter Database Management Console. Select Server, Server Setup from the main menu or right-click the server icon and select Server Setup from the popup menu. Follow the prompts in the DB Setup Wizard to add stored procedures and other required objects to the selected server.

Note: Server Setup is <not> required on DB2 UDB for z/OS and OS/390 and DB2 UDB for UNIX/Windows.


4.4 Platform Patch Requirements

These requirements are in addition to requirements stated elsewhere in this document.


Win32 Requirements

On Win32 platforms, the standard Microsoft ODBC administration, Driver Manager, Cursor Library, and standard ODBC Trace library must also be installed at minimum version of 3.510.3002.23 as seen in the About dialog for the ODBC Data Source Administrator.

Note: These Microsoft ODBC products are part of standard Windows installations.

The original edition of Windows 98 does not install the ODBC Driver Manager. The Windows 98 Second Edition installs the correct ODBC components. If you are running Window 98, the Second Edition is required.

Note: NT 4.0 CDs install version 3.02 of Microsoft ODBC software, which will not work with these drivers. As of 03/20/2001, the ODBC Install checks for the Microsoft ODBC Driver Manager support level, and will issue a warning dialog with an opportunity to abort if that support is not at least 3.51.

Microsoft has bundled their ODBC administration, ODBC Driver Manager and related software into their "Microsoft Data Access Components" (MDAC) package. As of 03/21/2001, the current MDAC GA version for all Win32 platforms is"MDAC 2.1.2.4202.3 (GA)". This can be found at: http://www.microsoft.com/data/download.htm

Look at Microsoft Universal Data Access - Free Downloads in the "MDAC 2.1 SP2" section. Click on the "Read the MDAC 2.1 release details" in that section, and then click Download MDAC 2.1.2.4202.3 (GA) to download the "MDAC 2.1.2.4202.3 (GA)" install.


AIX Requirements

Unicenter Database Management products require a minimum AIX full maintenance level of 4.3.3.0. Use the "oslevel" command to verify your current operating system version.


If you are connecting to Oracle 8.1.7 servers you need to have a minimum full maintenance level of 4.3.3.09.


The C++ run time library level on your system must be 4.0.2.0 or greater. If the C++ run time library level is less than that, the ODBC driver libraries cannot be dynamically loaded. An <ldd> run on any one of them will show a "Symbol <symbol> is not defined" error message where <symbol> will contain the characters
"Exception". For example,

  ldd ./ptor813s.so   exec(): 0509-036 Cannot load program ./ptor813s.so because of the   following errors:   0509-023 Symbol __setUncaughtExceptionFlag__3stdFb in   /opt/ca/caiptodbc/lib/libptbas13.a is not defined.

You can determine the C++ run time library level with

 /bin/lslpp -l | grep xlC.rte

which displays in columns similar to

 xlC.rte         4.0.2.0 COMMITTED C Set ++ Runtime

The software state in Column 3 can be APPLIED as well as COMMITTED. Any other state will cause a problem.

If the version number in Column 2 is less than 4.0.2.0, you must apply an IBM patch. AIX Patch ID <U463496> installs the 4.0.2.0 version.

The CAI/PT ODBC Unix install scripts enforce that the C++ run time library level is 4.0.2.0 or greater. If not, CAI/PT ODBC will not install.


Compaq Tru64 UNIX Requirements

The message "undefined symbol __cxx_call_static_dtors" in the middle of the ODBC part of the install, occurs if the version of libcxx on your machine is outdated. Unicenter Database Management uses the latest Compaq C++ compilers. However, in version 6.2 of Compaq's native C++ compiler, a bug fix regarding destruction of objects on unloading DLL from an application required an update to libc. To quote from the Compaq's C++ compiler release notes:

"The compilation system and run-time library now call destructors that are defined in shared images which have been closed correctly using dlclose(), with the linker option -depth_ring_search. This feature requires that a new libcxx be installed on your system with Version 6.2. Otherwise, the compiler reports the undefined symbol __cxx_call_static_dtors."

You will need version 6.2 of libcxx or newer. According to Compaq's documentation, version 4.0F ships with this library by default, but older versions of Tru64 UNIX do not.


Oracle8 on HPUX Requirements

If you are running an Oracle 8.0.x client on HPUX and connecting to Oracle8i (8.1.x) servers you will need to have a minimum patch level of 8.0.6.2.0.


4.5 Disabling Unicenter Enterprise DBA File Transfer Service

When installing on a machine that has a prior installation of Unicenter Enterprise DBA 5.2.0, the following message may display:

"The Enterprise Communicator components appear to be in use..."

If this message displays, you will be prompted to abort installation and perform the following steps before installing or upgrading any of the Unicenter Database
Management products:

  1. Open the Windows Services window.
  2. Look for "Unicenter Enterprise DBA File Transfer" service. If it exists, stop the service.
  3. Change the startup type for that service to "Disabled".

5.0 Contacting Technical Support

For further technical assistance with this product, contact Technical Support at http://ca.com for a complete list of locations and phone numbers. Technical support is available 24 hours a day, 7 days a week.

Chat with CA

Just give us some brief information and we'll connect you to the right CA Expert.

Our hours of availability are 8AM - 5PM CST.

All Fields Required

connecting

We're matching your request.

Unfortunately, we can't connect you to an agent. If you are not automatically redirected please click here.

  • {{message.agentProfile.name}} will be helping you today.

    View Profile


  • Transfered to {{message.agentProfile.name}}

    {{message.agentProfile.name}} joined the conversation

    {{message.agentProfile.name}} left the conversation

  • Your chat with {{$storage.chatSession.messages[$index - 1].agentProfile.name}} has ended.
    Thank you for your interest in CA.


    How Did We Do?
    Let us know how we did so that we can maintain a quality experience.

    Take Our Survey >

    Rate Your Chat Experience.

    {{chat.statusMsg}}

agent is typing