VMs are not displayed in the CA Spectrum side when integrated with CA UIM

Document ID:  TEC1016738
Last Modified Date:  06/20/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Spectrum

Releases

  • CA Spectrum:Release:10.2.1
  • CA Spectrum:Release:10.2
  • CA Spectrum:Release:10.1.2
  • CA Spectrum:Release:10.1.1
  • CA Spectrum:Release:10.1

Components

  • INTEGRATIONS:SPCINT
Problem:

After enabling the "VMware Management" option in the UIM Configuration of OneClick Administration page, only the vCenter host is modeled in UIM Manager --> Virtualization --> VMware folder. VMs and other items are missing. 

vmware_missing_VMs.png

Environment:
CA Spectrum 10.2.1 and CA UIM 8.51
Cause:

Hosting vCenters on virtual machines that are being monitored by a vmware probe can cause self/cross-hosting issues.

Resolution:

Solution: Set prevent_vcenter_correlation raw configure option as true in the vmware probe.

1. Make sure you are running the new vmware 6.60 probe 

2. Using Raw Configure, add the following to the <setup> section of the vmware probe config: 

prevent_vcenter_correlation = true 

vmware_Raw_Configure.png

vmware_New_Key.png

vmware_key_name.png

vmware_key_created.png

3. Deactivate the vmware probe. (Right-click on the vmware probe and choose Deactivate)

4. Use the discovery_server callback "remove_master_devices_by_cskeys" to delete the affected machines from discovery (or possibly clear it all out) . You can find the cskey from cm_computer_system table. Consult TEC000005096 for further information.

5. Activate the vmware probe. (Right-click on the vmware probe and choose Activate)

6. Deactivate and activate the discovery_server probe to rush a new discovery task, otherwise the discovery task will be launched in the evening. The discovery_server will take time to populate the data into the CA UIM database. You can monitor the probeDiscovery queue to see whether the discovery task has finished.

vmware_discovery_server_queue.png

Additional Information:

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