When a Task fail, Email Task isn't trigger.

Document ID:  TEC1116966
Last Modified Date:  06/07/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Identity Manager

Releases

  • CA Identity Manager:Release:12.6.8

Components

  • IdentityMinder(Identity Manager):IDMGR
Problem:

Customer created an e-mail policy to send e-mail alerts every time some specific tasks fail to complete. It was working for all selected tasks (create user, change password, request access, etc.) except for a custom Modify User task. The task was failing to complete but no e-mail was sent. Nothing available on the logs, even in debug.

Environment:
Identity Manager r12.6 SP8 (but this problem was seen in earlier releases prior to the upgrade)
Cause:

The task synchronization options were preventing the e-mail to be sent.

Resolution:

All tasks that were sending the e-mail in case of the task failed to complete had the Account Synchronization option set to "On every event", but the custom Modify User task had it set to "On task completion". After changing the Account Synchronization option to happen on every event (matching the other tasks) the e-mail was sent when the task failed to complete.

 

To change the Account Synchronization option, please do the following:

 

  1. As a System Manager, navigate to Roles and Tasks / Admin Tasks and select Modify Admin Task;
  2. Search and select the desired Admin Task;
  3. At the Profile tab, scroll down to find the Account Synchronization option;
  4. Change it to "On every event" and Submit.

 

Test again and you will see the e-mail being sent for the failed task.

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