When UIM service in Primary HUB Robot is restarted, we saw alarms from maintenance mode device.

Document ID:  TEC1189134
Last Modified Date:  06/08/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Unified Infrastructure Management

Releases

  • CA Unified Infrastructure Management:Release:8.4
  • CA Unified Infrastructure Management:Release:8.41
  • CA Unified Infrastructure Management:Release:8.42
  • CA Unified Infrastructure Management:Release:8.47
  • CA Unified Infrastructure Management:Release:8.5
  • CA Unified Infrastructure Management:Release:8.51

Components

  • UIM MAINTENANCE MODE:UIMMTM
  • UIM NAS:UIMNAS
Problem:

We have Robots which are currently in maintenance mode.
When the Primary Hub server is rebooted (for example, patching) alarms coming visible for the Robots which are still in maintenance mode.
The problem stopped automatically after for a while.

Environment:
UIM any version
Cause:

NAS probe acquire Maintenance policy data through maintenance_mode probe.

Upon UIM service restart on the Primary HUB Robot, NAS probe first connection attempt to maintenance_mode probe fails,

since NAS probe started faster than maintenance_mode probe.

NAS probe do not know current suppression policy until connection to maintenance_mode probe is repaired.

This is why you see alarm 'leaking' for device that is maintenance mode, and it automatically stops.

 

 

Workaround:

1. Deactivate NAS probe prior to undergo shutdown UIM service in the Primary HUB Robot.
2. Start UIM service in the Primary HUB Robot.
3. Activate NAS probe as post-task

You could also utilize "start_after" parameter in controller.cfg to force NAS probe to start after maintenance_moder probe is fully started.

Add the following line under <alarm_enrichment> section in controller.cfg in primary HUB Robot.

start_after = maintenance_mode


With this setting, alarm_enrichment probe (and nas probe) will be started after maintenance_mode probe is fully started.

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >

Chat with CA

Just give us some brief information and we'll connect you to the right CA ExpertCA sales representative.

Our hours of availability are 8AM - 5PM CST.

All Fields Required

connecting

We're matching your request.

Unfortunately, we can't connect you to an agent. If you are not automatically redirected please click here.

  • {{message.agentProfile.name}} will be helping you today.

    View Profile


  • Transfered to {{message.agentProfile.name}}

    {{message.agentProfile.name}} joined the conversation

    {{message.agentProfile.name}} left the conversation

  • Your chat with {{$storage.chatSession.messages[$index - 1].agentProfile.name}} has ended.
    Thank you for your interest in CA.


    Rate Your Chat Experience.

    {{chat.statusMsg}}

agent is typing