MSP Target Error when opening MSP due to wrong Bit level of the MSP Interface Installed

Document ID:  TEC1262892
Last Modified Date:  06/13/2017
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Products

  • CA PPM

Releases

  • CA PPM:Release:13.3
  • CA PPM:Release:14.1
  • CA PPM:Release:14.2
  • CA PPM:Release:14.3
  • CA PPM:Release:14.4

Components

  • CLARITY ON DEMAND INVSTMNTS, PRJCTS, RESOURCES & NPIO MGMT:ODINCL
  • CLARITY PPM INVSTMNTS, PRJCTS, RESOURCES & NPIO MANAGEMENT:PPMINV
Issue:

When opening Microsoft Project (MSP), receive one of two Target errors where the Error line reads either: "Error: Project cannot open the file." or "Error: Openfromdatabase"

Example of the Project cannot open the file error below:

targeterror.PNG

Environment:
This issue applies to all supported PAS environments for specified releases.
Cause:

This is typically due to the wrong MSP Interface bit level being installed. The MSP Interface bit level must match that of Microsoft Project. Example, if MSP's bit level is 64 bit, then the 64 bit level MSP interface should be installed. 

Resolution:

Perform a clean uninstall of the MSP Interface, then reinstall the MSP Interface with the correct version (that matches PPM) and bit level (that matches MSP) from PPM in Home->Account Settings->Software Downloads:

  • If your Microsoft Project Bit level is 32 bit download Microsoft Project Interface (x86)
  • If your Microsoft Project Bit level is 64 bit, download Microsoft Project Interface (x64)

Downloads.JPG

Additional Information:

- For Target errors including the "Openfromdatabase" error due to due to a corrupt Global.MPT see: TEC1338125

- For steps on how to do a clean uninstall of the CA PPM Microsoft Project Interface see: TEC1228411

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