Unable to log in to the CA Performance Manager (CAPM) OpenAPI interface.

Document ID:  TEC1335705
Last Modified Date:  07/06/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Performance Management

Releases

  • CA Performance Management:Release:3.1
  • CA Performance Management:Release:2.8
  • CA Performance Management:Release:3.0

Components

  • IM REPORTING / ADMIN / CONFIGURATION:IMADMN
  • CA PERFORMANCE CENTER:CAPRFC
  • IM DATA AGGREGATOR:IMAGGR
Problem:

No user is able to gain access to the OpenAPI user interface.

Logging in with any user with OpenAPI access shows the following behavior:

Log in with the correct user name and password, the log in prompt is returned again with no error message.

Log in with the wrong user name or password, the correct response showing incorrect user name or password used is returned.

Environment:
All CAPM releases
Cause:

The CA Data Aggregator (DA) and CA Performance Manager servers are out of synchronization for time.

When logging into the DA OpenAPI tool, the CAPM server provides user access control.

When logging in the DA requests SSO authorization for the users access from CAPM.

CAPM sends back an SSO token in the URL returned to the DA for valid user access authorization by the DA.

The token contains a value composed of different data points, including the current time. When the servers are not in synchronization for time, the SSO token fails to be read properly.

Resolution:

Set the CA DA and CAPM servers to the same time

Additional Information:

Best practice suggests use of an NTP server to ensure they are kept synchronized for time to avoid problems like this.

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