Cannot use DSM Explorer "Message timeout [AMM003004]"

Document ID:  TEC1392053
Last Modified Date:  07/10/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Client Automation

Releases

  • CA Client Automation:Release:12.8
  • CA Client Automation:Release:12.9
  • CA Client Automation:Release:14.0
  • CA Client Automation:Release:12.8 Feature Pack 1
  • CA Client Automation:Release:14.0 SP1

Components

  • CA Client Automation:BITCM
  • DESKTOP AND SERVER MANAGEMENT:DTSVMG
  • CA Asset Management:TNGAMO
  • CA Remote Control:TNGRCO
  • CA Software Delivery:TNGSDO
  • CA Patch Manager:UNIPTM
Issue:

Unable to open DSM Explorer . Error message: "Message timeout [AMM003004]".

Recycling AMManager will make DSM Explorer functional but after few hours timeout messages will re-appear.

Environment:
CA Client Automation - All Versions
Cause:

The problem could happen due to bad queries leading to timeouts as in GUI and AMManager crashes as shown in the AMManager log excerpt below:

00001124|AMManager |DbImpl_Ado |DbImpl_Ado |002311|NOTIFY | evalSQLInfo sqlstate: HYT00 native error: 0 0x0 
00001124|AMManager |CDb |DbImpl_Ado |002644|NOTIFY | Error Message: ADO Version 6.1 - COM Error:
ErrorCode:-2147217871,WordErrorCode:3121, IDispatch error #3121, Query timeout expired, Microsoft SQL Server Native Client 10.0, (null) 
00001124|AMManager | | |000000|ERROR | ################# HW Exception occurred [PID:7572] ################ 
Resolution:

The solution is to delete the bad queries.

1.   Get the list of bad queries. 

    use mdb
     select query_uuid,count(*) as cnt from ca_query_def_contents   
     group by query_uuid
     order by cnt desc

2.   Get the name of the specific bad query
   
    use mdb
     Select * from CA_QUERY_DEF where QUERY_UUID=SPECIFIC-UUID-FROM-ABOVE

 

3.    Remove the bad Queries. There are 2 ways to do this:

       A.  Thru SQL:

        use mdb
       Delete from CA_QUERY_DEF_CONTENTS WHERE QUERY_UUID=SPECIFIC-UUID-FROM-ABOVE
 
       B.  Thru the GUI
       
            Go to DSM Explorer and delete the Query manually
 
   *** If the Query is used by a Policy or Group, then you will need to delete the Policy or Group first ****
Additional Information:

These same Queries, if they are linked to a Dynamic Group or Policies can cause Performance issue even after the GUI is open.

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >

Chat with CA

Just give us some brief information and we'll connect you to the right CA ExpertCA sales representative.

Our hours of availability are 8AM - 5PM CST.

All Fields Required

connecting

We're matching your request.

Unfortunately, we can't connect you to an agent. If you are not automatically redirected please click here.

  • {{message.agentProfile.name}} will be helping you today.

    View Profile


  • Transfered to {{message.agentProfile.name}}

    {{message.agentProfile.name}} joined the conversation

    {{message.agentProfile.name}} left the conversation

  • Your chat with {{$storage.chatSession.messages[$index - 1].agentProfile.name}} has ended.
    Thank you for your interest in CA.


    Rate Your Chat Experience.

    {{chat.statusMsg}}

agent is typing