Xenapp probe 1.20 gives error “An unexpected exception occurred while testing the resource. Please retry your test.” when testing the resource config

Document ID:  TEC1420805
Last Modified Date:  07/14/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Unified Infrastructure Management

Releases

  • CA Unified Infrastructure Management:Release:8.51
  • CA Unified Infrastructure Management:Release:8.5
  • CA Unified Infrastructure Management:Release:8.47

Components

  • UIM - XENAPP:UIMXAP
Issue:
  • After upgrading the XenApp probe to 1.20 it cannot connect to the Citrix XenApp server.
  • When clicking test the error “An unexpected exception occurred while testing the resource. Please retry your test.” is received
  • Have verified all pre-requisite configurations have been made
  • kerberos is configured
  • WinRM is configured
  • the following is seen in the XenApp probe log at level 3

Error, Get-XAFarm: No connection could be established with "net.tcp: //xxxxxxxxxxxx: 2513 / Citrix / XenAppCommandsRemoting". The connection attempt has lasted for a period of 00: 00: 03.0420585. TCP Error Code 10061: A connection could not be established because the target computer denied the connection xxx.xxx.xxx.xxx:2513. 

Environment:
CItrix XenApp Server 6.5
Cause:
  • The XenApp probe requires the "Citrix XenApp Commands Remoting" service to be running on the Citrix XenApp Server.
  • This service tries to download the certification revocation list from Microsoft and if it does not succeed in a timely manner it will not start.
  • If the XenApp server does not have internet access then this service will never start
Resolution:
  1. Enable internet access on the XenApp Server

    OR

  2. Create a file called "Citrix.XenApp.Commands.Remoting.Service.exe.config" with the following contents: 

    <?xml version="1.0" encoding="utf-8"?> 
    <configuration> 
    <runtime> 
    <generatePublisherEvidence enabled="false" /> 
    </runtime> 
    </configuration> 

    Copy this file into: "C:\Program Files\Citrix\XenApp Commands" (assumes default install path)
    Restart the "Citrix XenApp Commands Remoting" service 

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >

Chat with CA

Just give us some brief information and we'll connect you to the right CA ExpertCA sales representative.

Our hours of availability are 8AM - 5PM CST.

All Fields Required

connecting

We're matching your request.

Unfortunately, we can't connect you to an agent. If you are not automatically redirected please click here.

  • {{message.agentProfile.name}} will be helping you today.

    View Profile


  • Transfered to {{message.agentProfile.name}}

    {{message.agentProfile.name}} joined the conversation

    {{message.agentProfile.name}} left the conversation

  • Your chat with {{$storage.chatSession.messages[$index - 1].agentProfile.name}} has ended.
    Thank you for your interest in CA.


    Rate Your Chat Experience.

    {{chat.statusMsg}}

agent is typing