False "MODULE REMOVAL DETECTED" alarms on Juniper devices in Spectrum

Document ID:  TEC1484773
Last Modified Date:  07/13/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Spectrum

Releases

  • CA Spectrum:Release:10.1
  • CA Spectrum:Release:10.0
  • CA Spectrum:Release:10.2

Components

  • ALARM & EVENT MGMT:SPCAEM
Issue:

False "MODULE REMOVAL DETECTED" alarms on Juniper devices in Spectrum. A check on the device shows no modules have been removed.

Cause:

A mismatch of information in the jnxContentsContainerIndex attribute of the jnxContentsTable and the jnxOperatingState attribute of the jnxOperatingTable in the jnxMibs on the device. Spectrum uses the information in these two tables to determine the module status. The following is an example:

686039_1.png

The above screen shot shows the contents of the jnxContentsContainerIndex and jnxOperatingState attributes from the same device.

Notice there are 72 values for the jnxContentsContainerIndex attribute but only 70 values for the jnxOperatingState attribute. Instance ID's 2.5.0.0 and 2.10.0.0 are missing from the jnxOperatingState attribute. These two tables should contain the same number of values with the same instance ID's. 

Resolution:

This is an issue with the vendors implementation of the mib and needs to be addressed with the vendor.

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >

Chat with CA

Just give us some brief information and we'll connect you to the right CA ExpertCA sales representative.

Our hours of availability are 8AM - 5PM CST.

All Fields Required

connecting

We're matching your request.

Unfortunately, we can't connect you to an agent. If you are not automatically redirected please click here.

  • {{message.agentProfile.name}} will be helping you today.

    View Profile


  • Transfered to {{message.agentProfile.name}}

    {{message.agentProfile.name}} joined the conversation

    {{message.agentProfile.name}} left the conversation

  • Your chat with {{$storage.chatSession.messages[$index - 1].agentProfile.name}} has ended.
    Thank you for your interest in CA.


    Rate Your Chat Experience.

    {{chat.statusMsg}}

agent is typing