Unable to Import files from CA WCC ECLI tab

Document ID:  TEC1563452
Last Modified Date:  07/18/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Workload Control Center

Releases

  • CA Workload Control Center:Release:11.3.6
  • CA Workload Control Center:Release:11.3.5

Components

  • WORKLOAD CONTROL CENTER:UWCC
  • CA Workload Automation AE (AutoSys):ATSYS
Issue:

Unable to import file from CA WCC ECLI tab; permission error sh: /tmp/wcc4598****.in: Permission denied" .

Environment:
CA WCC R11.3.6, R11.4 Operating System: AIX, Linux and Solaris
Cause:

ECLI uses AutoSys Command Sponsor installed on the CA WAAE host to perform command execution or JIL imports. AutoSys Command Sponsor is hosted by CA iTechnology iGateway.  When we execute a command or import a JIL file in ECLI, the WCC Credential user is used to create a temporary file in the CA WAAE server. If the user's umask value is not appropriate, the temporary file creation fails which results in the aforementioned permission error in ECLI.

Resolution:

1. Change to $IGW_LOC directory (/opt/CA/SharedComponents/iTechnology by default).

    cd $IGW_LOC

2. Edit the 'S99igateway' file using vi or vim.

3. Add the "umask 022" line just above the  "./igateway -b" in the script.




4. Add the "umask 022" line just above the  "./igateway -d" in the script

 

5. Restart iGateway service

    $ ./S99igateway stop

  $ ./S99igateway start

 

 

 

Additional Information:

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