New Data Repository installation shows error during validation of the connection properties for the database.

Document ID:  TEC1623703
Last Modified Date:  07/11/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Performance Management

Releases

  • CA Performance Management:Release:3.1
  • CA Performance Management:Release:3.0
  • CA Performance Management:Release:2.8

Components

  • IM DATA STORAGE:IMSTOR
  • IM REPORTING / ADMIN / CONFIGURATION:IMADMN
Problem:

When running the Data Repository validation script an error message is returned resulting in an inability for the installation to proceed.

The error states the following:

 

Validating connection to database host: DR_DB_Host.CA.com

Verifying database connection properties................................[FAIL]

Environment:
3.1 (applicable to all supported releases)
Cause:

At that point of its run, the validation script is performing a check for a DB connection. This check is only performed when the validation script believes there is already a DR DB installed. Why would that be in what should be a new installation run for the first time?

There as a past attempt to install the software that was not completed successfully. The failed installation was partially removed with the /opt/vertica directory remaining. This caused the validation script to believe it is an update not a new install.

Resolution:

Remove the failed install fully, including deleting the /opt/vertica directory.

Once done the validate script should no longer throw an error message.

Additional Information:

See Uninstall section of Installation section in CAPM Wiki docs for Vertica uninstall instructions.

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