Client Commands and WCC Quick View Searches Slow to Respond

Document ID:  TEC1724403
Last Modified Date:  06/12/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Workload Automation AE

Releases

  • CA Workload Automation AE:Release:11.3

Components

  • AUTOSYS RELEATED EEM:ATSEEM
  • CA Embedded Entitlements Manager:ETEIAM
Issue:

When running WCC Client Utilities such as 'autorep' or 'sendevent', the response time is intermittently slow. For example, running the command will come back immediately and then running the same command a few seconds later will take over 30 seconds to respond. The same behavior is experienced in WCC Quick View when searching for jobs.

Cause:

There can be a variety of root causes for slow performance of WAAE Client Utilities and WCC Quick View. However, this document focuses on one specific cause which is the performance of EEM authentication calls from the WAAE Application Server when EEM is configured to integrate with Active Directory.

When WAAE is enabled for EEM security, running client utilities and searching in Quick View will trigger an EEM authentication call from the Application Server. When EEM is slow to respond to that call, it will impact the performance of the client utility or Quick View search.

 

 

Resolution:

If EEM is configured to use Active Directory for the user store, and a User Attribute Map is in use to apply a group search filter, the Group Type selection for that filter can impact the performance of authentication calls.

group filter.JPG

For optimal performance, set the Group Type to "Use Group As Container".

 

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >

Chat with CA

Just give us some brief information and we'll connect you to the right CA ExpertCA sales representative.

Our hours of availability are 8AM - 5PM CST.

All Fields Required

connecting

We're matching your request.

Unfortunately, we can't connect you to an agent. If you are not automatically redirected please click here.

  • {{message.agentProfile.name}} will be helping you today.

    View Profile


  • Transfered to {{message.agentProfile.name}}

    {{message.agentProfile.name}} joined the conversation

    {{message.agentProfile.name}} left the conversation

  • Your chat with {{$storage.chatSession.messages[$index - 1].agentProfile.name}} has ended.
    Thank you for your interest in CA.


    Rate Your Chat Experience.

    {{chat.statusMsg}}

agent is typing