Device not associated with "All Manageable Devices", after discovery

Document ID:  TEC1739506
Last Modified Date:  07/17/2017
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Products

  • CA Performance Management

Releases

  • CA Performance Management:Release:3.1
  • CA Performance Management:Release:2.8
  • CA Performance Management:Release:2.7.0
  • CA Performance Management:Release:2.6
  • CA Performance Management:Release:3.0

Components

  • CA PERFORMANCE CENTER:CAPRFC
  • IM DATA AGGREGATOR:IMAGGR
Issue:

Device is discovered, but most metric families are listed as "Not Supported", when looking under "Polled Metric Families"

 

           For example; Device is discovered as a router and listed as active, but the only metric families that are listed as supported are "Reachability" and "Network Address"  

           Looking at http://<DA>/rest/devices/<ItemID>, they appear to be part of Manageable Devices, Routers and Switches.

<IsA name="IPDomainMember" rootURL="ipdomainmember"/>

<IsA name="Router" rootURL="devices/routers"/>

<IsA name="Switch" rootURL="devices/switches"/>

<IsA name="ManageableDevice" rootURL="devices/manageable"/>

<IsA name="Lifecycle" rootURL="lifecycle"/>

<IsA name="AccessibleDevice" rootURL="devices/accessible"/>

<IsA name="Syncable" rootURL="syncable"/>

<IsA name="MetricFamilyDiscoveryHistory" rootURL="devices/mfdiscoveryhistory"/> 

 

But when you look at the "Monitoring Profiles" tab, these collections are not listed, under "Related Collections"

 

 

Environment:
Performance Management all versions
Cause:

Discovery failed to associate this device with the collections, related to "All Manageable Devices", "All Routers" and "All Switches", even though the IsA settings on the device, indicate that they should be part of these collections

Resolution:

Manually add this device to the appropriate collections

1. Get the ItemID for this device, from the "Details" tab on the DA

2. Find the Collection ID, by querying the vertica database, on the Data Repository

A. Login as "dradmin" and run /opt/vertica/bin/admintools; then connect to database

B. Run the following queries, to get the collection ID for each of the missing collections

vsql>  select * from dauser.v_item where name = 'All Manageable Devices'

vsql>  select * from dauser.v_item where name = 'All Routers'

vsql>  select * from dauser.v_item where name = 'All Switches'

 

3. Then run the following, from the DA command line interface, for each collection that you are going to put this device into

curl -X PUT -d '</emptybody>' -H 'Content-Type: application/xml' http://localhost:8581/rest/groups/<CollectionID>/relatesto/devices/<ItemID>

 

 

Additional Information:

The device will now display the correct associated collections, on the "Monitoring Profiles" tab, Metric Families will show as "Supported" and you will soon be getting data

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