Error "Flexeraax0$aaa: Windows DLL failed to load" when trying to install Web Agent

Document ID:  TEC1765216
Last Modified Date:  06/20/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Single Sign-On

Releases

  • CA Single Sign-On:Release:12.52 SP1

Components

  • SITEMINDER -WEB AGENT FOR IIS:SMIIS
Issue:

When trying to run the R12.52 SP1 CR06 Web Agent installation wizard in Windows 2016 I am getting the following error while initializing:

This Application has Unexpectedly Quit
Invocation of this Java Application caused an
InvocationTargetException. This application will now exit. (LAX)

If I check the details available before quitting the installer I do see:

Flexeraax0$aaa: Windows DLL failed to load
at Flexeraax0.af(Unknown Source)
at Flexeraax0.aa(Unknown Source)
at com.zerog.ia.installer.LifeCycleManager.init(Unknown Source)
at com.zerog.ia.installer.LifeCycleManager.executeApplication(Unknown Source)
at com.zerog.ia.installer.Main.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.zerog.lax.LAX.launch(Unknown Source)
at com.zerog.lax.LAX.main(Unknown Source)

 

 

Environment:
Web Agent R12.52 SP1 CR06 on Windows Server 2016
Cause:

This error occurs when you are running a installer which is not supporting your current OS. As per current Platform Support Matrix, Windows Server 2016 is supported for R12.52 SP1 CR06, but it needs a special installer and not the common one.

Resolution:

For IIS10 on Windows Server 2016, you need to use a special R12.52 SP1 CR06 package instead, which is delivered separately:
https://support.ca.com/irj/portal/solncdndtls?aparNo=RS95103&os=ANY&fc=2&actionID=3

 

Additional Information:

Please help us improve!

Will this information enable you to resolve your issue?

Please tell us what we can do better.

{{feedbackText.length ? feedbackText.length : '0'}}/255

{{status}}

Not what you were looking for?

Search Again >

Product Information

Support by Product >

Communities

Join a Community >

Chat with CA

Just give us some brief information and we'll connect you to the right CA ExpertCA sales representative.

Our hours of availability are 8AM - 5PM CST.

All Fields Required

connecting

We're matching your request.

Unfortunately, we can't connect you to an agent. If you are not automatically redirected please click here.

  • {{message.agentProfile.name}} will be helping you today.

    View Profile


  • Transfered to {{message.agentProfile.name}}

    {{message.agentProfile.name}} joined the conversation

    {{message.agentProfile.name}} left the conversation

  • Your chat with {{$storage.chatSession.messages[$index - 1].agentProfile.name}} has ended.
    Thank you for your interest in CA.


    Rate Your Chat Experience.

    {{chat.statusMsg}}

agent is typing