probe_discovery queue is filling up

Document ID:  TEC1974379
Last Modified Date:  06/12/2017
{{active ? 'Hide' : 'Show'}} Technical Document Details

Products

  • CA Unified Infrastructure Management

Releases

  • CA Unified Infrastructure Management:Release:8.51

Components

  • UIM - DATA_ENGINE:UIMDEG
  • UIM - DISCOVERY:UIMDSC
Issue:

The probe_discovery queue is filling up with data and sending out alerts of being bigger that 1Gb.

Environment:
UIM 8.51 SP1. discovery_server 8.52 discovery_agent 8.52
Cause:

low Java Memory setting for the discovery_server probe

table indexes needs to be rebuild regularly

Resolution:

To allocate more (e.g. double) Java Memory for the discovery server probe open the raw configuration with Shift - right mouse click on the probe in IM.

select startup - opt

updating the following:


java_mem_max = -Xmx1024m

The above is the default what ever your value please double then deactivate and activate the probe to have it take affect.

We also recommend setting up a sql Job to run the following queries on a nightly basis:

ALTER INDEX ALL ON S_QOS_DATA REBUILD;
ALTER INDEX ALL ON CM_GROUP REBUILD;
ALTER INDEX ALL ON CM_COMPUTER_SYSTEM REBUILD;
ALTER INDEX ALL ON CM_COMPUTER_SYSTEM_ATTR REBUILD;
ALTER INDEX ALL ON CM_DEVICE REBUILD;
ALTER INDEX ALL ON CM_DEVICE_ATTRIBUTE REBUILD;
ALTER INDEX ALL ON CM_CONFIGURATION_ITEM REBUILD;
ALTER INDEX ALL ON CM_CONFIGURATION_ITEM_METRIC REBUILD;
ALTER INDEX ALL ON CM_CONFIGURATION_ITEM_ATTRIBUTE REBUILD;
ALTER INDEX ALL ON CM_CONFIGURATION_ITEM_DEFINITION REBUILD;
ALTER INDEX ALL ON CM_CONFIGURATION_ITEM_METRIC_DEFINITION REBUILD;
ALTER INDEX ALL ON NAS_ALARMS REBUILD;
ALTER INDEX ALL ON NAS_TRANSACTION_SUMMARY REBUILD;
ALTER INDEX ALL ON NAS_TRANSACTION_LOG REBUILD;

Next, in udm_manager.cfg:

1.)In the " Raw Configure" setup, add the following key under the " Setup" section: " schema_transact_retries" and set the value to 5000.

2.) Also change the "schema_connection_timeout_minutes" value to 30

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