CA Harvest Software Change Manager Plug-in for Eclipse - r12.0.x and r12.1.x
Update site

Welcome to the CA Software Change Manager Plug-in for Eclipse Update Site. Use this site to download the CA SCM Plug-in for Eclipse versions using the Eclipse Update Manager for automatic installation on your workstation. Follow the appropriate steps to install the CA SCM Plug-in for Eclipse.

Notes:

  • The release notes or readme file provides information about system requirements, operating system support, installation considerations, and known issues. Before installing the CA SCM Plug-in for Eclipse, read the appropriate version of the release notes or readme file, listed on this page in the Plug-in Compatibility Matrix.

  • For customer sites that do not permit end-user access to the CA SCM Plug-in for Eclipse Update Site, you can download a local, non-internet installation of the plug-in. You can download the Zip file from the Archived Update Site section.

  • If Linux or Microsoft Vista users face intermittent delays with the plug-in installation through eclipse update site, it is recommended to download the SCM_Eclipse_r12.x.zip and then proceed to install from the local archive.

  • Please ensure all the requirements for Eclipse plug-in are available before installation. The information about Eclipse plug-in requirements are at "Eclipse Requirements" (Page no 33) of release notes.

  • From CA Software Change Manager Release R 12.1 SP3,Eclipse plug-in dependencies are available for download in the Archived Update Section given below.

To install the CA SCM Plug-in using Eclipse 3.4

  1. In Eclipse, select Help, Software Updates.

    The installation wizard appears.

  2. Select the Available Software tab.

  3. Click Add Site.

  4. The Add Site dialog appears.

  5. In the Location field, enter the following URL:
    https://support.ca.com/phpdocs/0/255/harvesteclipse/

  6. This default URL points to the CA update site for the CA SCM Plug-in for Eclipse.

  7. Click OK.

  8. The new Support Online site is added to the list of available software sites, and is automatically scanned for possible updates.

  9. Select the check box next to the 12.0 plug-in version, and click Install to install the plug-in.

  10. When prompted to confirm the installation, click Finish.

  11. When prompted to restart Eclipse, click Yes.

  12. The CA SCM Plug-in for Eclipse is installed.

To install the CA SCM Plug-in using Eclipse 3.5

  1. In Eclipse, select Help, Install new software.

    The installation wizard appears.

  2. In the work with field,type the URL:
    https://support.ca.com/phpdocs/0/255/harvesteclipse/

    Click on Add.

  3. This default URL points to the CA update site for the CA SCM Plug-in for Eclipse.

  4. The new Support site is added to the list of available software sites, and is automatically scanned for possible updates.

  5. Select the check box next to the appropriate plug-in version, and click next to proceed to the licence agreement and complete the plug-in install.

  6. When prompted to confirm the installation, click Finish.

  7. When prompted to restart Eclipse, click Yes.

    The CA SCM Plug-in for Eclipse is installed

To install the CA SCM Plug-in using Eclipse 3.6

  1. In Eclipse, select Help, Install new software.

  2. The installation wizard appears.

  3. In the work with field,type the URL:
    https://support.ca.com/phpdocs/0/255/harvesteclipse/

  4. Click on Add.

  5. This default URL points to the CA update site for the CA SCM Plug-in for Eclipse.

  6. The new Support site is added to the list of available software sites, and is automatically scanned for possible updates.

  7. Select the check box next to the appropriate plug-in version, and click next to proceed to the licence agreement and complete the plug-in install.

  8. When prompted to confirm the installation, click Finish.

  9. When prompted to restart Eclipse, click Yes.

  10. The CA SCM Plug-in for Eclipse is installed.

To install the CA SCM Plug-in using Eclipse 3.7

  1. Download the SCMPluginForEclipse12.1.3.309a.zip to local file system.

  2. In Eclipse, select Help, Install new software. The installation wizard appears.

  3. In the work with field, Click on Add option.

  4. Add Repository prompt appears with local and archive options.

  5. Choose the archive option, provide a name and select the location of the locally copied archived zip file.

  6. Click on OK.The archived local copy will appear in the available software Sites list.

  7. Click on OK.

  8. In the work with field drop down list, choose the locally archived zip location.

  9. Select the check box next to the SP3 plug-in version and click Next. Install Details of the plug-in version to be installed will be displayed.

  10. Click next to proceed to the licence agreement and accept it.

  11. Click Finish to Complete the plug-in install. When prompted to restart Eclipse, click Yes.

The CA SCM Plug-in for Eclipse is installed.

To install the CA SCM Plug-in using Eclipse 4.2

  1. Download the dependencies from here to the local file system.

  2. In Eclipse, select Help, Install new software.

    The installation wizard appears.

  3. Select the Available Software Sites tab.

  4. Click Add Site.

  5. In the Location field, enter the location of the locally downloaded

    SCMPluginDependenciesForEclipse4.2.0. zip file. This points to the bundle of dependency zip files, which are prerequisites for the CA SCM Plug-In for Eclipse.

  6. Click OK.

    The archived SCMPluginDependenciesForEclipse4.2.0.zip is added to the list of available software sites.

  7. Select the appropriate check boxes next to the SCMPluginDependenciesForEclipse4.2.0.zip and click next to install the dependencies.

    Note: For more information about the check box selection, see the Dependencies selection in the below sections for appropriate IDE's.

  8. Click Finish, when prompted to confirm the installation.

  9. Click Yes, when prompted to restart Eclipse.

    The SCM dependencies for the CA SCM Plug-In for Eclipse are installed.

  10. Repeat step 5 again. In the Location field, enter the location of the locally downloaded plugin from here

    This points to the CA SCM Plug-In for Eclipse.

  11. Click OK.

    The CA SCM plug-in for r12.1 SP3 is added to the list of available software sites.

  12. Select the check box next to the r12.1 SP3 plug-in version, and click next to proceed and accept the license agreement to complete the plug-in installation.

  13. Click Finish, when prompted to confirm the installation.

  14. Click Yes, when prompted to restart Eclipse.

  15. Additionally download the jar from here. Extract and place it in the plugins folder of the Eclipse installation directory. This jar is used for the password storage mechanism in the Eclipse infrastructure.

  16. Restart the Eclipse to complete the plug-in installation.

    The CA SCM plug-in for Eclipse is installed.

    Note: If you see multiple login prompts after the plug-in installation, verify if the jar file mentioned in instruction step #15 is correctly installed in the plugins folder of the Eclipse installation.

To install the CA SCM Plug-in using Eclipse 4.3

  1. Download the dependencies from here to the local file system.

  2. In Eclipse, select Help, Install new software.

    The installation wizard appears.

  3. Select the Available Software Sites tab.

  4. Click Add Site.

  5. In the Location field, enter the location of the locally downloaded

    SCMPluginDependenciesForEclipse4.3.0. zip file. This points to the bundle of dependency zip files, which are prerequisites for the CA SCM Plug-In for Eclipse.

  6. Click OK.

    The archived SCMPluginDependenciesForEclipse4.3.0.zip is added to the list of available software sites.

  7. From the drop down, select the SCMPluginDependenciesForEclipse4.3.0.zip file.

    Dependencies for Eclipse4.3 will be displayed

  8. Select the appropriate check boxes next to the SCMPluginDependenciesForEclipse4.3.0.zip and click next to install the dependencies.

    Note: For more information about the check box selection, see the Dependencies selection in the below sections for appropriate IDE's.

  9. Click Finish, when prompted to confirm the installation.

  10. Click Yes, when prompted to restart Eclipse.

    The SCM dependencies for the CA SCM Plug-In for Eclipse are installed.

  11. Repeat step 5 again. In the Location field, enter the location of the locally downloaded plugin from here

    This points to the CA SCM Plug-In for Eclipse.

  12. Click OK.

    The CA SCM plug-in for r12.1 SP3 is added to the list of available software sites.

  13. Select the check box next to the r12.1 SP3 plug-in version, and click next to proceed and accept the license agreement to complete the plug-in installation.

  14. Click Finish, when prompted to confirm the installation.

  15. Click Yes, when prompted to restart Eclipse.

    The CA SCM Plug-In for Eclipse is installed.

 

To install the CA SCM Plug-in r12.1SP3 using Eclipse 4.4:

Follow these steps:

  1. Download the dependencies SCMPluginDependenciesForEclipse4.4.0.zip and extract it to local folder on your machine.

  2. In Eclipse, select Help, Install new software. The installation wizard appears.

  3. Select the Available Software Sites tab.

  4. Click Add Site. The Add Site dialog appears. Provide the name.

  5. In the Location field, enter the location of the local folder where you have already extracted the dependencies.

  6. This points to the bundle of dependency files, which are prerequisites for the CA SCM Plug-In for Eclipse.

  7. Click OK.

    Select the dependencies from the Work with drop down menu.

  8. The list of all dependencies is displayed.

  9. Select the appropriate check boxes next to the dependencies list and click next to install the dependencies.

    Note: For more information about the check box selection, see the Dependencies selection for appropriate IDE's.

  10. Click Next.

  11. Accept the license and click Finish, when prompted to confirm the installation.

  12. Click yes, when prompted to restart Eclipse.

    The SCM dependencies for the CA SCM Plug-In for Eclipse 4.4 is installed.

  13. Repeat steps 3, 4 and 5 again. In the Location field, select the archive option, enter the location of the locally downloaded CA SCM plug-in SCMPluginForEclipse12.1.3.309b.zip

  14. This points to the CA SCM Plug-In for Eclipse.

  15. Click OK.

    The CA SCM plug-in for r12.1SP3 is added to the list of available software sites.

  16. Select the check box next to the plug-in version, and click next to proceed and accept the license agreement to complete the plug-in installation.

  17. Additionally download the jar from here .Extract and place it in the plugins folder of the Eclipse installation directory. This jar is used for the password storage mechanism in the Eclipse infrastructure.

  18. Restart the Eclipse to complete the plug-in installation.

    The CA SCM plug-in for Eclipse is installed.

    Note: If you see multiple login prompts after the plug-in installation, verify if the jar file mentioned in instruction step #17 is correctly installed in the plugins folder of the Eclipse installation.

 

Important Note:

For 4.4 dependencies installation, extract the dependencies to a local directory or folder. To install these dependencies, in the add repository wizard, click on the Local option to specify the directory location of the extracted dependencies and proceed further.

For 4.2 and 4.3 dependencies installation, the process remains same as earlier i.e. it is bundled as an archived zip file. In the add repository wizard, click on the Archive to specify the name of the dependencies and proceed further and extract it to local folder on your machine.

News

  • March 31, 2015
    CA SCM Plug-in for Eclipse r12.1.03 is now certified with Eclipse 4.4. This plug-in is compatible with CA SCM r12.1.03

  • May 19, 2014
    CA SCM Plug-in for Eclipse r12.1.03 is now certified with RAD 8.5 and RAD 9.0. This plug-in is compatible with CA SCM r12.1.03.

  • August 29, 2013
    CA SCM Plug-in for Eclipse r12.1.03 is now certified with Eclipse 4.3.This plug-in is compatible with CA SCM r12.1.03.

  • February 04, 2013
    CA SCM Plug-in for Eclipse r12.1.03 is now certified with Eclipse 4.2.This plug-in is compatible with CA SCM r12.1.03.

  • February 07, 2012
    CA SCM Plug-in for Eclipse r12.1.03 is now certified with Eclipse 3.7.This plug-in is compatible with CA SCM r12.1.03.

  • January 09, 2012
    CA SCM Plug-in for Eclipse r12.1sp3 is now available. This release contains a plug-in version for Eclipse 3.6, 3.5, 3.4.2. This plug-in is compatible with CA SCM r12.1sp3.

  • June 01, 2011
    CA SCM Plug-in for Eclipse r12.1.02 is now certified with Rational Application Developer 8.0.2 on Windows. This plug-in is compatible with CA SCM r12.1.02.

  • May 19, 2011
    CA SCM Plug-in for Eclipse r12.1.02 is now available. This release contains a plug-in version for Eclipse 3.6, 3.5, 3.4.2. This plug-in is compatible with CA SCM r12.1.02.

  • December 12, 2010
    CA SCM Plug-in for Eclipse r12.1.01 is now certified with Eclipse 3.6 on Windows. This plug-in is compatible with CA SCM r12.1.01.

  • October 21, 2010
    CA SCM Plug-in for Eclipse r12.1.01 is now available. This release contains a plug-in version for Eclipse 3.5, 3.4 and 3.3. This plug-in is compatible with CA SCM r12.1.01.

  • April 28, 2010
    CA SCM Plug-in for Eclipse r12.1 is now available. This release contains a plug-in version for Eclipse 3.5, 3.4 and 3.3. This plug-in is compatible with CA SCM r12.1.

  • July 10, 2009
    CA maintenance release r12 Fix Pack 2 (12.0.2) of the CA SCM Plug-in for Eclipse is now available. This release contains a plug-in version for Eclipse 3.4, 3.3 and 3.2.2.

  • April 15, 2009
    CA maintenance release r12 Fix Pack 1 (12.0.1) of the CA SCM Plug-in for Eclipse is now available. This release contains a plug-in version for Eclipse 3.4, 3.3 and 3.2.2. This plug-in is compatible with CA SCM r12 and CA SCM r12 FP1.

  • December 11, 2008
    CA maintenance release 7.20.3 of the CA Harvest Plug-in for Eclipse is now available. This release contains a plug-in version for Eclipse 3.4,3.3 and 3.2. This plug-in is compatible with CA Harvest r7.1 SP2 which is also GA now.

  • November 14, 2008
    CA Software Change Manager Plug-in for Eclipse r12 has now successfully validated the Ready for IBM Rational software v7.0.4 at Eclipse Level requirements. The certification has been completed with build 12.0.0.Build042, an update to the GA build of SCM Plug-in for Eclipse r12. To obtain additional information on the benefits of the Ready for IBM Rational validation, reference the Ready for IBM Rational program on IBM's web site.

  • September 10, 2008
    CA announces r12 of the CA SCM Plug-in for Eclipse. This release integrates with CA SCM r12 made generally available in August 2008. The CA SCM r12 plug-in includes many new features such as enhanced refactoring support, item and lifecycle history diagrams, support for all lifecycle processes, new forms support, enhanced concurrent development, and many others. Refer to the r12 Plug-in Release Notes for additional information on these exciting new features, many of which are also common to the new r12 workbench. This plug-in is supported with Eclipse 3.4, 3.3, and 3.2.2.

  • June 19, 2007
    CA maintenance releases 7.20.2 and 6.20.2 of the CA Harvest Plug-in for Eclipse are now available. This release suite contains a plug-in version for Eclipse 3.1/3.2 and 3.0. These plug-ins are compatible with both CA Harvest r7 Patch 4 with Hotfix PR6027 (Improve Eclipse Synchronization Performance) and forthcoming CA Harvest r7.1 SP1.

  • For Eclipse 3.1 or 3.2, install the CA Harvest Plug in for Eclipse version 7.20.2.
  • For Eclipse 3.0, install the CA Harvest Plug in for Eclipse version 6.20.2.

Note that Eclipse SDK 2.1 and Websphere Studio Application Developer Integration Edition 5.1.x support is not included in this maintenance update.

For more information, see the Release Notes and fixed issues lists.

 

Plug-in Compatibility Matrix

CA SCM Plug-in Version Compatible Eclipse Version Compatible IBM IDEs Version Compatible CA SCM Versions Release Notes
12.1.03 4.4
4.3
4.2
3.7
3.6
3.5
3.4.2
RAD r7.5, RAD r7.5.5, RAD r8.0.2, RAD 8.5, RAD 9.0 CA SCM r12.1 SP3 Please refer to https://support.ca.com for release notes and user guide.
12.1.02 3.6
3.5
3.4.2
RAD r7.5, RAD r7.5.5, 8.0.2 CA SCM r12.1 SP2 Please refer to https://support.ca.com for release notes and user guide.
12.1.1 3.5
3.4
3.3
RAD r7.5, r7.5.5 CA SCM r12.1 SP1 Release Notes
User Guide
12.1.0 3.5
3.4
3.3
RAD r7.5 CA SCM r12.1 Release Notes
User Guide
12.0.2 (r12 FP2) 3.4
3.3
3.2.2
Rational Application Developer 7.0.x. Also compatible with RAD r7.5. CA SCM r12 FP2 Readme
Fixed Issues
12.0.1 (r12 FP1) 3.4
3.3
3.2.2
Rational Application Developer 7.0.x. Also compatible with RAD r7.5. CA SCM r12, CA SCM r12 FP1 Readme
Fixed Iissues
7.20.3 3.4
3.3
3.2
Rational Application Developer 7.0.0.3 CA Harvest Change Manager r7.1 SP2 Readme
Fixed Issues
12.0.0.Build042 3.4
3.3
3.2.2
Rational Application Developer 7.0.0.7 CA SCM r12 Release Notes
User Guide
12.0.0 3.4
3.3
3.2.2
Rational Application Developer 7.0.0.7 CA SCM r12
6.20.2 3.0 Rational Application Developer 6.0, WebSphere Development Studio Client for iSeries 6.0 AllFusion Harvest r7 Patch 4 w/hotfix PR6027, CA Harvest r7.1 SP1 Readme,
Fixed Issues
7.20.2 3.1, 3.2 * Note 1 AllFusion Harvest r7 Patch 4 w/hotfix PR6027, CA Harvest r7.1 SP1

 

Note: Websphere Studio support from the CA Harvest Plug-in for Eclipse has been stabilized as IBM has expired support for the primary configurations of Websphere Studio Developer. Eclipse SDK 2.1 is also no longer supported by Eclipse.org. We recommend customers upgrade to the newer, replacement versions of Eclipse SDK or Rational Application Developer.

 

Archived Update Site

Before installing Eclipse plug-in for r12.1SP3, you need to download and install the dependencies based on your Eclipse version.

  • For Eclipse 3.4.2 download the dependencies from here
  • For Eclipse 3.5 download the dependencies from here
  • For Eclipse 3.6 download the dependencies from here
  • For Eclipse 3.7 download the dependencies from here
  • For Eclipse 4.2 download the dependencies from here
  • For Eclipse 4.3 download the dependencies from here
  • For Eclipse 4.4 download the dependencies from here
    Note: During the above dependencies installation,
  • For Eclipse IDE for Java developers and Classic IDE, select all the features from the corresponding dependency archive zip.
  • For Eclipse IDE for JEE developers, select Birt and zest features from the dependency archive zip.
  • For RAD 7.5.0, select the GEF, Draw2d and zest features from the dependency archive zip.
  • For RAD 7.5.5 and 8.0.2, choose only the SCM plug-in (No need to install dependencies).
  • RAD 8.5
    The pre-requisites are:
    1. For RAD 8.5, download the Eclipse 3.6 dependencies from the support site from here and install only the zest binaries from the bundle and then proceed to install the SCM plug-in.
    2. Additionally we need to install an authentication jar from here and include it in the plugins folder of the RAD installation For Ex: Download and extract the jar into this sample RAD Home install location on your windows machine
      C:\Program Files\IBM\IBMIMShared\plugins

  • RAD 9.0
    The pre-requisites are:
    1. Download and install GEF-Update-3.8.2.zip from here.
    2. Additionally we need to install an authentication jar from here and include it in the plugins folder of the RAD installation.
      For Ex: Download and extract the jar into this sample RAD Home install location on your windows machine
      C:\Program Files\IBM\IBMIMShared\plugins

After the dependencies install, please download Eclipse plug-in for r12.1SP3 from here and install.

If you need to configure a local update site of the r12 plug-in where users can install the plug-in from a local archive, download the SCM_Eclipse_r12.x.zip file. This zip file contains only the following plug-in:

  • 12.0.0
  • 12.0.0.Build042
  • 12.0.1 (r12 FP1)
  • 12.0.2 (r12 FP2)
  • 12.1.0
  • 12.1.1 (r12.1 SP1)
  • 12.1.02 (r12.1 SP2)

If you need to configure a local update site where users can install plug-in versions from a local archive, download the HarvestEclipse.zip file, which contains older plug-in versions:

  • 7.20.3
  • 6.20.2
  • 7.20.2
  • 5.20.1
  • 6.20.1
  • 7.20.1

Right-click and select Save As: SCM Eclipse r12.x.zip or HarvestEclipse.zip based on your selection.
Store this file in a networked location where users can access it for installation.
End-users can install the archived plug-ins from the local archive file from the Eclipse environment.

To install the archived plug-ins in Eclipse

  1. Click Help, Software Updates, Find and Install.

    The Install/Update wizard opens.

  2. Select Search for new features to install and click Next.

  3. Click New Archived Site.

    The Select Local Site Archive dialog box opens.

  4. Navigate to and select the file you downloaded, and then click Open.

  5. Perform one of the previous installation procedures for your version of Eclipse.

Chat with CA

Just give us some brief information and we'll connect you to the right CA ExpertCA sales representative.

Our hours of availability are 8AM - 5PM CST.

All Fields Required

connecting

We're matching your request.

Unfortunately, we can't connect you to an agent. If you are not automatically redirected please click here.

  • {{message.agentProfile.name}} will be helping you today.

    View Profile


  • Transfered to {{message.agentProfile.name}}

    {{message.agentProfile.name}} joined the conversation

    {{message.agentProfile.name}} left the conversation

  • Your chat with {{$storage.chatSession.messages[$index - 1].agentProfile.name}} has ended.
    Thank you for your interest in CA.


    Rate Your Chat Experience.

    {{chat.statusMsg}}

agent is typing